MercuryMarauder.net Forums    

Go Back   MercuryMarauder.net Forums > Marauder High Performance > Drag Racing Round-up

Drag Racing Round-up Up-to-date drag racing information......

Reply
 
Thread Tools Display Modes
  #31  
Old 10-31-2018, 07:57 AM
376shovel 376shovel is offline
Senior Member
 

Join Date: Jan 2016
Location: South NJ
Posts: 394
Trader: (1)
Quote:
Originally Posted by justgod View Post
With that convertor, you should be leaving at a much higher RPM. You'll be in a better torque band to leave on and get that 60ft down a hair.
Other than that, spark advance and AFR are the only changes if everything else is solid. Ever try manual shifts? It engages the gears a little different inside the trans.
All good advice, but ive had to dig deeper, may not have the balancer tightened enough against the reluctor wheel.

3200 PI actually. Ive always had better luck with several cars flashing the xonverter or leaving right off idle. Regardless, that doesnt explain the lack of mph. Yhe car is down on power and there is a reason i have yet to find.
__________________
2003 Marauder 300A
#2928 of 7838
Build date: 8/6/02
Ship date: 5/28/03
14.33 @ 96.82 with old engine
New engine times in fall

1968 Chevelle 376
NA/Pump Gas 10.4 @ 128 mph
Reply With Quote
  #32  
Old 10-31-2018, 08:38 AM
justgod's Avatar
justgod justgod is offline
Senior Member
 

Join Date: Nov 2009
Location: NH
Age: 50
Posts: 172
Trader: (0)
You said Marty remote tuned it. Get a wideband if you don't have one and the tune can be tweaked better. Maybe get a tune with added timing for the track and put MS109 in the tank...
Reply With Quote
  #33  
Old 10-31-2018, 10:32 AM
Agent2006 Agent2006 is offline
Member
 

Join Date: Jun 2017
Location: Oxford, PA
Posts: 87
Trader: (0)
Suggestion -swap out the TC. Those 60' times are hardly better than stock, unless there was a ton of wheelspin. Maybe you are blowing through the torque converter. how did it feel? Any excessive revving?
Reply With Quote
  #34  
Old 10-31-2018, 11:50 AM
376shovel 376shovel is offline
Senior Member
 

Join Date: Jan 2016
Location: South NJ
Posts: 394
Trader: (1)
Yes i have an LC-2 providing the wideband.

It spins a hair at the track but nothing to write home about. It flashes to 32-3300. On the street it burns the tires good from a 5 mph roll. Way better than pre converter. Before the converter it wouldnt spin from a dead stop...

It doesnt feel like its blowing through, at the traps im 5000-5100 rpm, 96 mph. I will break out the trans slippage calculator.
__________________
2003 Marauder 300A
#2928 of 7838
Build date: 8/6/02
Ship date: 5/28/03
14.33 @ 96.82 with old engine
New engine times in fall

1968 Chevelle 376
NA/Pump Gas 10.4 @ 128 mph
Reply With Quote
  #35  
Old 10-31-2018, 01:35 PM
martyo's Avatar
martyo martyo is offline
MO derator
 

Join Date: Jan 2003
Location: Hiram, Georgia
Age: 56
Posts: 17,692
Trader: (27)
Please look at what we spent the last 18 hours discussing.

Pretty please.
__________________
Reply With Quote
  #36  
Old 10-31-2018, 04:45 PM
vkirkend's Avatar
vkirkend vkirkend is offline
Delaware Marauderer
 

Join Date: Apr 2006
Location: Smyrna, DE
Age: 67
Posts: 1,729
Trader: (3)
Quote:
Originally Posted by Joe Walsh View Post
As you, I, and many others have found:
Getting a 2+ ton car with an automatic to run fast with a 281 CID N/A V8 is a challenge!

If you pour money into it...AND add some cubes you can run 12s N/A.
But the smart folks immediately go to forced induction.
What he said....
__________________
2004 MM (Black) #112 of 3213 (SOLD)
2003 MM (BLACK #5444 of 7838 (FOR SALE)
"BLACK MAMBA" (fomerly owned by Chris Wright)
Cowl Induction Hood
2.9 Whipple
4.6 MMR Motor
4L80E Trans
Stainless 3" Exhaust
631 RWHP/569 RWTQ
AND-
2005 Dodge Ram 1500
Flame Red
Quad Cab SRT-10 (Automatic)
500 hp Viper Engine (stock)
4.56 Posi-Rear (Factory) (stock)
-AND-
SLAYER1
formerly owned by "Impala Slayer!! 2004 SB MM
Kenne Belle 2.6, MMR "Boss 302" Block, Kooks Headers and cats, Accusump Pre-Oiler Dynamax VT mufflers, MBS 2 1/2" exhaust, 4.10's, 2800 stall, Argento 312 "Color" Powder coated wheels, Rears widened 1 1/2 ",591 HP/555 TQ on 93 Octane, M/M catch can, 3 pillar gauge (Boost, Fuel, air intake and coolant temp, custom console cover, S-55 treatment.
Reply With Quote
  #37  
Old 11-17-2018, 05:15 PM
376shovel 376shovel is offline
Senior Member
 

Join Date: Jan 2016
Location: South NJ
Posts: 394
Trader: (1)
Quick update for the group:

Compression test revealed roughly 180 psi across the engine. Except for cyl 5 and 6 at 130 psi. Leakdown shows 60% leakage on both. Listened and couldnt hear where the air was going. I'm thinking head gasket. I will be swapping out the drivers head gasket soon.

At least I've found the issue. It explains why I'm down on power for sure.
__________________
2003 Marauder 300A
#2928 of 7838
Build date: 8/6/02
Ship date: 5/28/03
14.33 @ 96.82 with old engine
New engine times in fall

1968 Chevelle 376
NA/Pump Gas 10.4 @ 128 mph

Last edited by 376shovel; 11-17-2018 at 06:49 PM.
Reply With Quote
  #38  
Old 11-17-2018, 06:40 PM
1Marauder's Avatar
1Marauder 1Marauder is offline
Senior Member
 

Join Date: Nov 2012
Location: Sacramento
Posts: 3,255
Trader: (5)
Quote:
Originally Posted by 376shovel View Post
UPDATE:


Alright ladies and gents. Grab your scream masks and take a seat for this vent session. This here is a tough pill to swallow for me, but here goes. A while ago I grabbed a whole 2005 aviator engine from a junkyard. I rebuilt it, .020 over, flat tops (10.5:1), 99 cobra intake cams advanced 4 degrees. I also put in a used 3500 converter from a member on this site. Then Marty (who has been awesome) remote tuned the car for me. After all of these upgrades, tonight I ran a whopping 14.249 @ 95.92....
5.941
9.123 @ 77.24
11.888
14.249 @ 95.92


Again this is with a new NA engine 10.5:1, 99 cobra cams, headers, 3500 converter, 4.10 gears. still in the 14s. the DA tonight was below 0... Only thing I can think of it some sort of restriction in the exhaust? I got two bad cats in a row which broke apart in my exhaust, I wonder if there is some sort of clog in there.


This timeslip was the first and best run of the night. very sad stuff guys. here is a video of my piece of shlt car that I just may get mad enough to sell. Yay.


https://www.youtube.com/watch?v=OS_ZCWzqJQI

That was amazing. I want that car!
__________________


2003 300A Black, #4918 of 7838, 17,400 Miles
Tune, KYB's, JLT, FlowMaster 42441, Res Delete, New BFG's, 8 coats of zymoil Titanium

2003 300B Silver Birch, #21 of 419, 29,800 miles
Tune, JLT, FlowMaster 42441 Res Delete, New Nitto 235/255 Bigcarsforever dead peddle & custom SRP peddles, 5 coats Zymoil Titanium, Addco front and rear sway bars, KYBs, 1/2 inch coil cut, Sparts Watts link and Control Arms, Car fixer alignment.
Reply With Quote
  #39  
Old 11-17-2018, 06:50 PM
376shovel 376shovel is offline
Senior Member
 

Join Date: Jan 2016
Location: South NJ
Posts: 394
Trader: (1)
Quote:
Originally Posted by 1Marauder View Post
That was amazing. I want that car!
Is that sarcasm
__________________
2003 Marauder 300A
#2928 of 7838
Build date: 8/6/02
Ship date: 5/28/03
14.33 @ 96.82 with old engine
New engine times in fall

1968 Chevelle 376
NA/Pump Gas 10.4 @ 128 mph
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Marauder served me well on my trip... CKMustangCobra Community Discussion 4 01-27-2009 07:59 AM
Marauder's First trip to the track Eric91Z Community Discussion 8 10-17-2005 08:50 AM
MARAUDER SIGHTINGS: My trip to MA today Dan Community Discussion 0 10-03-2004 03:29 PM


All times are GMT -7. The time now is 01:43 AM.


Powered by: vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©2002 - 2017 - MercuryMarauder.net